PHP.SU

Программирование на PHP, MySQL и другие веб-технологии
PHP.SU Портал     На главную страницу форума Главная     Помощь Помощь     Поиск Поиск     Поиск Яндекс Поиск Яндекс     Вакансии  Пользователи Пользователи


 Страниц (1): [1]   

> Без описания
dadli
Отправлено: 23 Мая, 2011 - 11:04:23
Post Id



Посетитель


Покинул форум
Сообщений всего: 416
Дата рег-ции: Май 2011  
Откуда: тифилис


Помог: 5 раз(а)




добрые времени суток, мне вот такая проблема: в пхп фаиле руские симболи атабражается как знаки вопроса - ??????.
мне установлена локални сервер - "денвер" и кагда на етом локалном сервере тестирую пхп фаил, всо работает отлично, но когда на удаленном (настаящем) сервере тестирую, уже виводит знаки вопроса - ??????.
ето значит што мои настаящи сервер не "настаящи", а хлам, который не подерживает руские симболи? ета так?
можно как то убратъ ету проблему?


вот код пхп фаила:

CODE (html):
скопировать код в буфер обмена
  1. <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
  2. <html xmlns="http://www.w3.org/1999/xhtml">
  3. <head>
  4. <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
  5. <title>title</title>
  6. </head>
  7.  
  8. <body>
  9.  
  10.  
  11. <?php
  12.  
  13. echo "привет";
  14.  
  15. ?>
  16.  
  17.  
  18. </body>
  19. </html>
 
 Top
Ejas Tower
Отправлено: 23 Мая, 2011 - 11:34:12
Post Id



Гость


Покинул форум
Сообщений всего: 68
Дата рег-ции: Май 2011  
Откуда: Уфа


Помог: 0 раз(а)




А ваш браузер поддерживает UTF-8?
 
 Top
dadli
Отправлено: 23 Мая, 2011 - 11:47:24
Post Id



Посетитель


Покинул форум
Сообщений всего: 416
Дата рег-ции: Май 2011  
Откуда: тифилис


Помог: 5 раз(а)




если проблема в броузере, в случе локалном сервере тоже должен бит не нормално отображаться симболи да? знаки вопросов виводит толко тагда, когда фаил лежит на удаленном сервере, а на локалном сервере, руские симболи виводится нормално.
 
 Top
ugin_root
Отправлено: 23 Мая, 2011 - 11:50:34
Post Id


Частый гость


Покинул форум
Сообщений всего: 134
Дата рег-ции: Май 2011  
Откуда: Киргизия


Помог: 5 раз(а)




dadli
попробуйте в самом начале файла добавить
PHP:
скопировать код в буфер обмена
  1. <?PHP
  2.     header("Content-type:text/html;charset=utf-8");
  3. ?>

и естественно кодировка файла доложна быть "utf-8 без BOM"
 
 Top
Zuldek
Отправлено: 23 Мая, 2011 - 11:51:18
Post Id


Постоянный участник


Покинул форум
Сообщений всего: 2122
Дата рег-ции: Июнь 2010  


Помог: 50 раз(а)




пропишите в файле ".htaccess"
AddDefaultCharset UTF-8
Если такового нет, то создайте и закиньте в один каталог с вашей страницей.
P.S. Старайтесь писать без ошибок
 
 Top
dadli
Отправлено: 23 Мая, 2011 - 11:56:25
Post Id



Посетитель


Покинул форум
Сообщений всего: 416
Дата рег-ции: Май 2011  
Откуда: тифилис


Помог: 5 раз(а)




харашо, попробую ваши совети, благадарю за ответи
 
 Top
Newbee
Отправлено: 23 Мая, 2011 - 12:20:19
Post Id


Новичок


Покинул форум
Сообщений всего: 44
Дата рег-ции: Май 2011  


Помог: 0 раз(а)




У меня денвер тоже стоит, была такая же проблема. Но нужно всего-то поменять кодировку самого сервера! Или, если поможет сначала в самом php или html файле прописать кодировку, если не помогает, вот делай так:


Путь для смены кодировки на локальном сервере:

Z -> usr -> local -> apache -> conf -> httpd.conf:

заходим в диск Z и открываем папку usr
в папке usr открываем папку local
дальше нужно открыть папку apache и в ней открыть папку conf.
в папке conf найти файл httpd.conf и открыть его программой Блокнот.
найти строку AddDefaultCharset windows-1251 и изменить, например на AddDefaultCharset utf-8.




кодоровка в Денвере

После перезагрузки Денвера и очистки кэша браузера, все будет работать как вам нужно.
Можно сделать еще по-другому. Найти в том-же файле httpd.conf строку с установкой кодировки, и закомментировать - #AddDefaultCharset windows-1251, тогда будут действовать установки сайта, прописанные в < meta http-equiv="content-type" content="text/html; charset=utf-8" /> ,
что бывает очень удобно.

(Отредактировано автором: 23 Мая, 2011 - 12:21:51)

 
 Top
movEAX
Отправлено: 23 Мая, 2011 - 18:13:03
Post Id



Частый посетитель


Покинул форум
Сообщений всего: 750
Дата рег-ции: Авг. 2009  


Помог: 16 раз(а)




mysql_query('SET NAMES utf8');


-----
армия.. самое убогое место
 
 Top
dadli
Отправлено: 24 Мая, 2011 - 13:10:55
Post Id



Посетитель


Покинул форум
Сообщений всего: 416
Дата рег-ции: Май 2011  
Откуда: тифилис


Помог: 5 раз(а)




Newbee, в моем случе на локалном сервере - денвере, всо отлично работает, Улыбка проблема иестъ на удаленном сервере.

movEAX, ета помогает когда из бази данних виводит знаки вопросов да? а мои скрипт такои елементарни:

PHP:
скопировать код в буфер обмена
  1. <?PHP
  2. echo "привет"; // виводит - ??????
  3. ?>



p.s.
я на две другом удаленном сервере тестировал пхп фаил и на оба сервере все харашо работает, русский текст виводит нормално, (и нормално работает на локалном сервере - денвере), мне кажется иест некоторые хостери, котерие хлам дают и просто нада такои хлам не купитъ. Улыбка ну и спасибо всем за ответи.

(Отредактировано автором: 24 Мая, 2011 - 13:11:39)

 
 Top
nikob
Отправлено: 24 Мая, 2011 - 13:53:13
Post Id


Новичок


Покинул форум
Сообщений всего: 58
Дата рег-ции: Апр. 2011  


Помог: 1 раз(а)




dadli пишет:
Newbee, в моем случе на локалном сервере - денвере, всо отлично работает, Улыбка проблема иестъ на удаленном сервере.

movEAX, ета помогает когда из бази данних виводит знаки вопросов да? а мои скрипт такои елементарни:

PHP:
скопировать код в буфер обмена
  1. <?PHP
  2. echo "привет"; // виводит - ??????
  3. ?>



p.s.
я на две другом удаленном сервере тестировал пхп фаил и на оба сервере все харашо работает, русский текст виводит нормално, (и нормално работает на локалном сервере - денвере), мне кажется иест некоторые хостери, котерие хлам дают и просто нада такои хлам не купитъ. Улыбка ну и спасибо всем за ответи.


при сохранении файла php выюерите кодировку сохранения UTF-8
 
 Top
dadli
Отправлено: 24 Мая, 2011 - 15:11:29
Post Id



Посетитель


Покинул форум
Сообщений всего: 416
Дата рег-ции: Май 2011  
Откуда: тифилис


Помог: 5 раз(а)




вот в чом била проблема: нужна при сохранении в кодировке utf-8 убрат галочку BOM и всо работает супер.

dadli пишет:
мне кажется иест некоторые хостери, котерие хлам дают и просто нада такои хлам не купитъ


маио извиненя у "некоторых хостеров", я виноват Это скорее хорошо чем плохо
 
 Top
Страниц (1): [1]
Сейчас эту тему просматривают: 1 (гостей: 1, зарегистрированных: 0)
« Кодировки и все смежное »


Все гости форума могут просматривать этот раздел.
Только зарегистрированные пользователи могут создавать новые темы в этом разделе.
Только зарегистрированные пользователи могут отвечать на сообщения в этом разделе.
 



Powered by PHP  Powered By MySQL  Powered by Nginx  Valid CSS  RSS

 
Powered by ExBB FM 1.0 RC1. InvisionExBB