PHP.SU

Программирование на PHP, MySQL и другие веб-технологии
PHP.SU Портал     На главную страницу форума Главная     Помощь Помощь     Поиск Поиск     Поиск Яндекс Поиск Яндекс     Вакансии  Пользователи Пользователи


 Страниц (1): [1]   

> Описание: �����
hehagog545
Отправлено: 29 Сентября, 2020 - 00:07:15
Post Id


Новичок


Покинул форум
Сообщений всего: 11
Дата рег-ции: Авг. 2020  


Помог: 0 раз(а)




Всем привет!
Трабл с кодировкой, везде где только можно utf-8 посылаю.

опенсервер:
апач 2.4 (utf-8 по умолчанию)
пхп 7.4 (utf-8 по умолчанию)
Страница браузера также рапортует, что отображает в utf-8
даже .htaccess создал с AddDefaultCharset utf-8 Огорчение
сервер перезагружал, после изменений в настройках

Куда ещё можно покопать? Однако
Имеем код:
PHP:
скопировать код в буфер обмена
  1.  
  2. <?PHP
  3. header('charset=utf-8');
  4. $some = 'какао - горькое питьё';
  5. echo $some; // всё правильно выводится
  6. echo "<br/>";
  7. echo $some[0]; // а вот тут такое -> &#65533; Почему такое вылазит?
  8.  

Итог вывода в браузере:

    какао горькое питьё

Основной вопрос: почему рус текст норм выводится, а символ нет?
Растерялся

(Отредактировано автором: 29 Сентября, 2020 - 09:30:27)

 
 Top
hehagog545
Отправлено: 29 Сентября, 2020 - 09:45:10
Post Id


Новичок


Покинул форум
Сообщений всего: 11
Дата рег-ции: Авг. 2020  


Помог: 0 раз(а)




ответ
Спойлер (Отобразить)

закрыто
 
 Top
Страниц (1): [1]
Сейчас эту тему просматривают: 1 (гостей: 1, зарегистрированных: 0)
« Вопросы новичков »


Все гости форума могут просматривать этот раздел.
Только зарегистрированные пользователи могут создавать новые темы в этом разделе.
Только зарегистрированные пользователи могут отвечать на сообщения в этом разделе.
 



Powered by PHP  Powered By MySQL  Powered by Nginx  Valid CSS  RSS

 
Powered by ExBB FM 1.0 RC1. InvisionExBB