Форумы портала PHP.SU » Серверное администрирование » Apache и другие веб-серверы » Установка php5 на удалённый сервер

Страниц (1): [1]
 

1. Mister - 30 Марта, 2011 - 20:20:33 - перейти к сообщению
Помогите решить проблему
Есть хостинг с php 4.4.7, необходимо чтобы на нём работал php5 (конкретно движок на joomla, сам движок ставится, но при обращении к некоторым пунктам в админпанели появляется ошибка), как это можно сделать, если к хостингу есть доступ только по ftp, на нём работают файлы htaccess и есть доступ к папкам cgi и public_html?
2. JustUserR - 31 Марта, 2011 - 21:48:22 - перейти к сообщению
Mister пишет:
Необходимо чтобы на нём работал php5
В качестве возможного варианта решения предполагаемой задачи, заключающейся в осуществлении мануального определения конфигурации сопоставляемых виртуальных URL-элементов, допустимо использование механизмов alias-инга и действенного перенаправления, позвоялющего обеспечить выполнение требуемых действий на основании выполнения выбора базового элемента, выполняющего генерацию HTTP-документа ответа пользователю
Для осуществления корректного функционирования предполагаемой формы реализации поставленной задачи, необходимо проведение предшествующий действий по оргиназации создания корректного исполнемого приложеня PHP-интерпретатора на системного базовом уровне элементного трактования, а также определение целевых параметров среды окружения, на основании которых допустимо извлечения корреткных путей включения зависимых файловых объектов; кроме того для осуществления корректного функционирования решения допустимо использование модулей расширения типа suexec, на основании которых возможно осуществление переназначения ассоциированных параметров исполняемого процесса
3. DeepVarvar - 31 Марта, 2011 - 23:04:49 - перейти к сообщению
Mister компилить пхп с нужными модулями и класть его в папку cgi вместе с php.ini.
Или искать уже скомпиленый и настроеный такой же вариант.
4. OrmaJever - 31 Марта, 2011 - 23:27:18 - перейти к сообщению
Mister пишет:
Есть хостинг с php 4.4.7
А?!
А такие бывают? Попробуйте написать администрации хостинга что бы обновили php
5. evgenijj - 01 Апреля, 2011 - 04:23:17 - перейти к сообщению
OrmaJever пишет:
Попробуйте написать администрации хостинга что бы обновили php

Гиблый вариант. Хостер на это не пойдет. У него на этом серваке еще несколько сотен сайтов. Он ПО обновит по запросу одного клиента, а еще у 10 (50, 100) скрипты сломаются. Совместимость сверху->вниз не всегда работает. Для хостера это серьезная работа. И никто по доброй воле на это не пойдет.
6. JustUserR - 02 Апреля, 2011 - 21:24:17 - перейти к сообщению
DeepVarvar пишет:
Или искать уже скомпиленый и настроеный такой же вариант.
Для осуществления корректного функционирования предполагаемой формы реализации поставленной задачи, необходимо проведение предшествующий действий по оргиназации создания корректного исполнемого приложеня PHP-интерпретатора на системного базовом уровне элементного трактования, а также определение целевых параметров среды окружения, на основании которых допустимо извлечения корреткных путей включения зависимых файловых объектов; кроме того для осуществления корректного функционирования решения допустимо использование модулей расширения типа suexec, на основании которых возможно осуществление переназначения ассоциированных параметров исполняемого процесса

 

Powered by ExBB FM 1.0 RC1