Форумы портала PHP.SU » Серверное администрирование » Apache и другие веб-серверы » Проблемы при загрузки файла изображения в папку на сервер через веб-форму. Сервер apache c IIS

Страниц (1): [1]
 

1. nastya111 - 17 Декабря, 2019 - 07:13:01 - перейти к сообщению
привет. Прошу совета, не знаю куда копать уже
Сразу скажу код весь рабочий - это было выяснено опытным путем ( дальше опишу) , так что проблема не в нем,
Есть специфический сайт. На нем есть форма загрузки на сервер изображения.
При попытке загрузить изображения сайт обновляется и изображение пропадает, соответственно не сохраняется никуда.
Нормальное поведение сайта это - после добавление обновиться -и вывести миниатюру добавленного изображения.
Все библиотеки в php.ini как либо связанные с изображениями подключены.
Была попытка запустить на xampp - всё запустилось и изображения добавляется (конечно я предварительно убила IIS) ( код, как я и говорила рабочий), но тогда переставала работать отправка почты пользователям, я конечно же всё заменила, чтобы почта работала, но нет
Потом я сравнила 2 Php.ini и добавила всё то, чего не было в старом php.ini, то есть в IIS
Скажу, что проект не мой, если был бы мой, я бы знала что делать
Подскажите, что делать с IIS, что еще подключить?
или что то еще сделать
2. LIME - 17 Декабря, 2019 - 11:14:16 - перейти к сообщению
код молча не отказывает
надо смотреть ошибки выставив максимальный уровень error_reporting(может меняться и в php.ini и в коде переопределяться)
логи вебсервера

 

Powered by ExBB FM 1.0 RC1