Форумы портала PHP.SU » PHP » Программирование на PHP » php_mailparse.dll для PHP 5.0.0

Страниц (1): [1]
 

1. EuGen - 26 Июня, 2007 - 10:14:32 - перейти к сообщению
Столкнулся с проблемой: на php.net можно найти только php_mailpase.dll для PHP 5.2.x , но она, естественно, не загружается для php 5.0.0 (ошибка PHP Startup: Unable to load dynamic library 'c:phpextphp_mailparse.dll' - Не найдена указанная процедура). Ну с ошибкой то более менее все ясно, ничего неожиданного в ней нет. А вот существует ли все таки php_mailparse.dll, которая загрузится на моем дистрибутиве - вопрос Вам.
По ряду причин не могу сделать апгрейд до 5.2, так что нужна именно для 5.0.0.
2. valenok - 26 Июня, 2007 - 10:40:44 - перейти к сообщению
если есть то на dll.ru
3. EuGen - 26 Июня, 2007 - 10:46:05 - перейти к сообщению
Спасибо за ответ! Но, к сожалению, там не удалось найти нужной dll библиотеки (там, я так понял, они по алфавиту упорядочены, и идет: php_php_ldap.dll, потом срузу php_ldap.dll, v 1.0.0.0).
4. valenok - 26 Июня, 2007 - 11:03:45 - перейти к сообщению
http://pecl.php.net/package/mailparse

Требования: PHP Extension: mbstring
Вот её искать на dll.ru или php.net .там есть
5. EuGen - 26 Июня, 2007 - 11:29:48 - перейти к сообщению
Да, я тут опечатался, там в имени dll которое я привел, конечно же, не "php_php_..." а просто "php_..." и следующую dll я тоже неверно указал (она там с именем "php_m..."). Про mbstring я нашел в документации. Самое интересное, что mbstring в поставку расширений для версии 5.0.0 входит (то есть соответствующая dll библиотека там присутствует).
7. EuGen - 26 Июня, 2007 - 12:01:05 - перейти к сообщению
К сожалению, версия предлагаемой там dll аналогична той что я скачивал ранее (а именно 5.1.7 / 5.1.7.7). Скорее всего, я оттуда ее и скачивал (потому что в google я, как ранее говорил уже, искал этот файл). Мне удалось найти и более позднюю версию библиотеки (версии 5.2.3). Однако и найденная сейчас библиотека версии 5.1.7 также (как и 5.2.3) не смогла загрузиться. Впрочем, я думаю, что для php 5.0.0 не исключен и вариант невозможности загрузки этой библиотеки. В любом случае спасибо за ответы.

 

Powered by ExBB FM 1.0 RC1